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Geografiske Informationssystemer (GIS) er ved at blive et meget anvendt værktøj til håndtering af data inden for biologien. GIS opstod som et redskab til forvaltning af enheder med geografisk udbredelse og er først og fremmest udviklet af geografer med henblik på forvaltning og kommerciel anvendelse. De første GIS-programmer krævede et omfattende kendskab til teorien bag geografisk databehandling og foregik i et rent tekstbaseret miljø.

Udviklingen af bedre hardware og mere brugervenlig software har imidlertid gjort det muligt for folk med ikke-geografisk baggrund at anvende GIS i det daglige arbejde og på deres egen desktop computer. For biologer betyder det, at hvor man før er blevet nødt til at anvende statiske omveje for at inddrage rumlig/geografisk information i analysen, er det nu blevet muligt at gøre det gennem en visuel overflade og som en mere rutinemæssig faktor i arbejdet.
Samlingerne på Zoologisk Museum giver, ud over den systematiske information, en enestående mængde viden om arters udbredelser. For at denne information fremover kan blive anvendt bedst muligt, er digitalisering et vigtigt element, og herunder er GIS et oplagt redskab. 
Hensigten med denne introduktion er at give en grundlæggende indføring i mulighederne for at bruge geografiske informationssystemer til museumsrelevante og biologiske opgaver. Introduktionen henvender sig først og fremmest til VIP’er, TAP’er og studerende ved Zoologisk Museum, som gerne vil have et overblik over mulighederne med GIS og gerne vil lære at bruge GIS som et almindeligt redskab i det daglige arbejde.

Da kurset er ganske kort, lægges der vægt på en anvendelsesorienteret tilgang til GIS og mindre på den omfattende bagvedliggende teori, som interesserede selv vil kunne læse sig til.

I kurset vil følgende emner blandt andet berøres:

· Generel introduktion til GIS

· Kortproduktion med egne punktdata

· Geografisk analyse – eksempler på beregninger af geografisk udbredelse, arealer og afstande 

· Vektor og raster. Hvilke data og hvilke opgaver?

· Tilpasning af GIS til særlige opgaver – udvidelser, brugerflader, makroer og programmering

· Offentliggørelse og samarbejde omkring geografiske data over intra- og Internettet.

Undertegnede er projektansat på fugleafdelingen på Zoologisk Museum og arbejder med GIS og analyseredskaber til ringmærkningsdata.

Morten Bjerrum, 2003

Start med ArcGIS 8.3
Øvelse 1
Brug ArcCatalog

Her skal I navigere i ArcCatalog og se lidt på forskellige data

ArcCatalog er en form for ”Stifinder” til styring af geografiske data. På stisystemet til venstre kan du navigere i mapperne på din computer (samt andre steder, f.eks. på internettet) og i vinduet til højre kan du se filerne i de enkelte mapper. Ligesom med Windows Stifinder kan du kopiere, slette filer og flytte dem ved at trække i dem med musen.

· Start med at åbne ArcCatalog i Programmer>ArcGIS>ArcCatalog
· I stisystemet til venstre, gå til C:\GIS-data\lektion1\tabeller. Kig nu på det højre vindue. Her er tre faneblade foroven, ”Contents”, ”Preview” og ”Metadata”. Hvis ”Contents” er valgt, kan du se indholdet af den valgte mappe.

· Marker tabellen ”FUGLENAVNY.DBF” ved at klikke på den en enkelt gang.
· Prøv at vælge ”Preview”. Her får du simpelthen en del af filens indhold at se, hvis det drejer sig om et format ArcCatalog kan håndtere, f.eks. d-base filer som den valgte eller geografiske data. MS word eller Excel dokumenter kan eksempelvis ikke ses. 
· Vælg nu fanebladet ”Metadata” i det højre vindue. Her er der mulighed for at se ”data om data”, såkaldte metadata. I selve vinduet er der igen tre faneblade. Vælg fanebladet ”Attributes”. Her er der information om tabellens opsætning, bl.a. kan man se, at der er 347 records. Prøv nu at klikke på de grønne ”Attributes”, f.eks. ”NYEURING”. Her ses det, at feltet er af typen ”Number” og at det har bredden 20. 
· Gå nu over til venstre og vælg i stedet GIS-data\lektion1\temaer\cntry98.shp og se på filens data til højre, særligt ”Preview”. 

· Læg mærke til, hvordan de forskellige filer under Temaer har forskellige ikoner, afhængigt af deres datatype. 
Dette var blot en kort introduktion til ArcCatalog. Der er mange yderligere funktioner, hvoraf vi vil vende tilbage til nogle senere. I første omgang skal ArcCatalog bruges til at håndtere geografiske data og desuden kan man trække data direkte herfra og over i ArcMap, som vi nu skynder os videre til
Videre til ArcMap
ArcMap er det program vi først og fremmest skal arbejde med. Det er det grundlæggende desktop GIS program, hvor langt de fleste GIS funktioner udføres og hvor du ser resultaterne på kort. 

ArcMap er et meget dynamisk program, som den enkelte bruger kan indrette efter behov. Der er en lang række værktøjslinier, som man kan slå til og fra og man kan udvide programmet med egne funktioner eller kommercielle udvidelser.

I skal starte med at åbne et nyt projekt og hive nogle grunddata ind og fremstille dem på et kort.
· Start med at oprette en mappe på c-drevet der hedder Gis-projekter, dvs. ”c:\gis-projekter\”

· Her kan du gemme alle dine projekter og filer sammen, sådan at du har styr på dem. Det er MEGET VIGTIGT at holde styr på sine filer, for ikke senere at få problemer (nu er det sagt). 
· Åben ArcMap: Programmer>ArcGIS>ArcMap
· Vælg file>Save As og gem projektet som ”c:\gis-projekter\spurvehøg.mxd”
· Vælg File>Add Data og gå til ”c:\gisData\lektion1\temaer”. Marker filerne ”Newkystii.shp”, ”cntry98.shp”, ”reservatprj.shp”, ”Spurvehoegmaerk.shp” og ”Spurvehoeggenf.shp”. Hold ”Shift” nede for at vælge flere filer. Tryk ”Add”
· Du har nu indlæst fem temaer (eller Layers)  i ”Table Of Contents” (TOC). De kan gøres synlige ved at afkrydse firkanten til venstre for navnet. Tænd og sluk for de forskellige temaer

· Prøv ved hjælp af værktøjerne på værktøjslinjen at zoome ind og ud og panorere (med ”hånden”). Ved tryk på ”Globen” zoomes der ud til en samlet oversigt over alle temaer.
· ArcMap tegner kortene i rækkefølgen nedefra og opefter i TOC. Ved at trække i et tema med musen kan du flytte det i forhold til de andre temaer. Prøv at se, hvordan de øverste kort dækker over de nederste.

Hvis man klikker en enkelt gang på et tema, fremhæves det. Temaet er nu aktivt. Det aktive tema er ofte det, som man udfører operationer på. Ved at holde Shift nede kan man gøre flere temaer aktive på én gang.
Ved at højreklikke på et tema får man adgang til en del funktioner. 

· Vælg ”Zoom to layer”. Denne funktion zoomer til det valgte temas fulde størrelse.
· Gem projektet: file>Save
· Det er en god ide at gemme jævnligt. Man ved jo aldrig, hvad der kan ske!

· Prøv nu at fjerne et tema ved at højreklikke på det og vælge ”Remove”. Åben dernæst ArcCatalog henover ArcMap og træk temaet ind i ArcMap igen med musen.

· Gem projektet

Øvelse 2

Sæt signaturer

Her skal I prøve at ændre måden at vise data på. Dette gøres kun i ArcMap, da det er her kort produceres, og her er der et stort udvalg af symboler og farver. Desuden kan man gruppere (eller klassificere) både ordinale og kontinuerte data på en lang række måder, alt efter, hvad man ønsker at vise og fremhæve med sit kort. 
· Åben ”spurvehøg.mxd” i ArcMap, hvis den ikke allerede er åben

· I TOC er der en gul figur oppe over temaerne. Det er en såkaldt ”Data Frame”. Der kan være flere ”data frames” i et projekt, men kun et kan være aktivt. Det er disse data man ser i vinduet til højre. En data frame tilføjes ved at vælge Insert>Data Frame og den gøres aktiv ved at højreklikke på den og vælge Activate
· Markér den oprindelige data frame ”Layers” og tryk på den en enkelt gang igen, for at ændre navnet på den. Navngiv den ”Danske reservater”

· Højreklik på ”Danske reservater” og vælg Properties. Nu får du mulighed for at indstille en masse egenskaber, som gælder for alle temaer i samme data frame. Prøv f.eks. at gøre baggrunden blå, ved at vælge Frame>Background og sæt den til blå. Tryk Apply.
· Vis temaerne ”Newkystii.shp” og ”Spurvehoeggenf.shp”. Sluk de andre.

· Højreklik på temaerne, vælg Properties>General og giv dem nye navne: ”Spurvehøggenfund” og ”Danmark”

· Under temaets Properties, vælg Symbology og se, hvordan du nu kan ændre og indstille signaturerne/symbolerne for temaet. Leg lidt med mulighederne for at illustrere temaerne og prøv at give landekortene en behagelig farve. Tryk Apply for at se det på kortet.
· Prøv at finde en god signatur for ”Spurvehøggenfund”

· Vis genfund af spurvehøg i forskellige farver, efter årstiden fuglen er mærket på. Kolonnen Gfmaan er mærkningsmåneden. Vælg nu Quantities>Graduated Colors og Fields>Value=Gfmaan. På knappen Classify kan I vælge Equal Interval og 4 klasser.
Øvelse 3

Se på baggrundsdata

Her skal I prøve at finde informationer fra de underliggende data bag GIS-kortet. 

· Tænd og aktivér temaet spurvehøggenf. Vælg værktøjet ”Identify”, som er en cirkel med et I på værktøjslinjen.

· Prøv at trykke på én af prikkerne og se, hvordan et vindue med tabelinformationen for den enkelte prik kommer op

· Prøv at vælge andre temaer i vinduet og se på deres information

· Højreklik på et tema og vælg ”Open attribute table”. Se, hvordan tabellen bag data nu bliver åbnet i et nyt vindue.
· Gå tilbage til kortet. Aktiver spurvehøggenf og vælg værktøjet ”Select features”. Træk en firkant omkring nogle af prikkerne og se at de vælges (bliver blå). Åben igen tabellen, og se, hvordan de samme poster er blevet valgt i tabellen.

· Bliv i tabelvinduet og vælg ”Show Selected records” forneden. Nu vil man kun se de valgte poster i tabellen, sådan at man ikke bliver ”besværet” af alle de øvrige.
· Prøv ligeledes at markere nogle poster i tabellen, og se, hvordan de bliver blå på kortet. 
Øvelse 4

Lav et ”Layout”

Her skal du prøve at lave et udskrivningsklart ”Layout”. Et Layout er en nem måde at gøre sine data og kort udskrivningsklare på.
· Sæt dit kortvindue til ”Layout View” ved at trykke på den lille knap i nederste venstre hjørne af kortvinduet. Nu ændres kortet til at vise en A4 side, som den vil se ud ved udskrift. Desuden åbnes bjælken ”Layout” med layout værktøjer.

· Zoom ind, panorér og indstil signaturerne, sådan at kortet ser ud som du kunne tænke dig

· Gå til layout bjælken og vælg værktøjet yderst til højre ”Change Layout”. Nu får du mulighed for at vælge en standard-skabelon ”Template” til dit layout. 

· Ved hjælp af værktøjerne på layout bjælken kan du zoome rundt i dit layout og ved hjælp af punkterne under Insert kan du sætte titel, nordpil og meget andet på dit layout. Prøv f.eks. at sætte en målestokslinje i kilometer på. Højreklik på elementerne for at sætte og rette i deres egenskaber (properties).
· Du har nu lavet et udskrivningsklart layout. Du kan udskrive det ved at vælge File>Print, men da vi ikke har nogen printer tilkoblet, må du vente til en anden dag. Sørg for at gemme dit projekt, spurvehoeg.mxd.

Øvelse 5
Forespørgsler

Forespørgsler er et af hovedelementerne i GIS. Ved en forespørgsel udvælger man data på basis af bestemte kriterier og disse kriterier kan være på tabelvariable, ligesom man kan gøre i traditionelle databaser, eller på geografiske kriterier, som f.eks. at finde punkter, der ligger inden for et bestemt område. Det er i kombinationen af tabelforespørgsler og geografiske forespørgsler at GIS er noget helt særligt.

Nu skal I prøve at stille en forespørgsel på en tabelvariabel (”Attributes”), sådan at prikker (mere korrekt ”features”) der opfylder et bestemt krav bliver farvet blå (selected). 

· Zoom sådan at man kan se alle prikker i spurvehoeggenf.shp (højreklik på temaet og vælg ”Zoom To Layer”) og tænd for cntry98.shp

· Vælg Selection>Select by attributes. Nu åbnes der et vindue, hvor I kan vælge temaet ”Layer” spurvehoeggenf.shp, som det tema I vil vælge poster i. Vælg metoden ”Create a new selection”. Dette vælger et helt nyt sæt baseret på alle poster i tabellen. Metoden ”Add to current selection” ville lægge de udvalgte poster til allerede valgte poster (en OR – operation), mens ”Select from current selection” ville vælge blandt allerede udvalgte poster (en AND – operation). 

· Længere nede i vinduet er der mulighed for at opstille en forespørgsel i et logisk udtryk, en såkaldt ”Query”, som skrives i en simplificeret udgave af sproget SQL. Forespørgslen skrives ved hjælp af felternes navne, operatorerne og værdier, som man kan vælge fra boksen til højre eller selv skrive ind

· Prøv nu at vælge alle genfund som er fundet mere end 100 km fra mærkningsstedet. Dette kan gøres ved at konstruere udtrykket ”ORTHODIST” > 100. For at se, om du har konstrueret udtrykket ordentligt, før du kører forespørgslen kan du trykke på knappen Verify. Tryk derefter Apply.
· Luk vinduet, og se, hvordan alle genmeldinger der lever op til kravet (Orthodist>100), er blevet farvet blå.

· Åben nu tabellen for genfundene. Læg mærke til, hvor mange poster der er blevet udvalgt ud af totalen (390/1725).

· Vælg Options>Switch selection og se, hvordan der byttes om på udvalget, sådan at det nu er de 1335/1725 andre poster der er valgt, (dvs. de områder, hvor Orthodist<= 100).
· Nu vil vi gerne have fat i de genfund der både er uden for Danmark (”Country<>”Danmark”) og opfylder kravet Orthodist>100.  Prøv at løse opgaven ved hjælp af ”Select by attributes”, enten som et nyt udvalg eller ved at bygge videre på den forrige selection. Læg mærke til, at ”Select by attributes” også kan åbnes under ”Options” i tabelvinduet. Der skulle nu gerne være valgt 323/1725 poster.

En geografisk/rumlig forespørgsel

Nu skal I vælge alle mærkninger som ligger inden for EF-fuglebeskyttelsesområder.

· Lav en ny data frame, som indeholder temaerne spurvehoegmaerk og Effuglebeskomrprj.shp (ligger under lektion1/temaer/beskyttelsesomrader)

· Navngiv temaerne ”Mærkning af spurvehøg” og ”EF fuglebeskyttelsesområder”

· Prøv at løse opgaven ved hjælp af funktionen Select>Select By Location. 
· Hvis du løser opgaven rigtigt, kan du se, at kun punkter, som ligger indenfor fuglebeskyttelsesområderne bliver udvalgt
· Du kan nu gemme disse data separat, ved at højreklikke på ”Mærkning af spurvehøg” og vælge Data>Export date og derefter specificere, hvor det nye tema skal gemmes. Gem temaet i din egen mappe under et nyt, relevant navn. Du bliver spurgt, om du vil lægge det nye tema til data frame’n. Svar Ja og se på det nye tema.

· Gem projektet

Prøv også at vælge alle mærkninger der ligger inden for en radius af 5 km fra et EF-fuglebeskyttelsesområde. Brug igen Selection>Select by Attributes. Der skulle gerne være 581 valgte poster.
Øvelse 6

Tabelfunktioner

I skal nu prøve at sortere i en tabel og finde nogle ekstreme værdier i den.

· Åben tabellen for genfund af spurvehøg. Markér kolonnen ”Ringtid”, ved at trykke på kolonnenavnet. 

· Højreklik på kolonnenavnet og vælg hhv. ”Sort ascending” og ”Sort descending” og se, hvordan tabellen sorteres på baggrund af det valgte felt. 

· Find den største og mindste genmeldingsafstand (Orthodist) og den højeste alder (Leveaar)

· Højreklik på kolonnen ”Leveaar” og vælg Statistics. Her får du lidt simpel statistik på feltet over de valgte poster, f.eks. de 323 udvalgte poster fra øvelse 5.

Nu skal vi prøve at flette to tabeller (”Join”). Den ene tabel er tabellen fra spurvehoeggenf.shp.
· Først vil vi trække en almindelig dBase fil ind i projektet. Denne fil rummer ingen geografisk information, men kan bidrage med andre oplysninger, som vi f.eks. kan flette sammen med en tabel fra et tema. Selvstændige tabeller kan ikke normalt ses i TOC, men hvis du går ned til venstre i TOC og vælger fanebladet ”Source”, vil du kunne se de enkelte temaers sti, samt altså enkeltstående tabeller. 

· For at importere en dBase fil, vælger du som ved et tema File>Add Data. Find tabellen ”Kategorifork.dbf” i mappen c:\GisData\lektion1\tabeller. Importer tabellen og se den i TOC.
· Højreklik nu på ”Genfund af spurvehøg” og vælg Joins and Relates>Join. Flet nu de to tabeller sammen, baseret på fælles værdier i feltet/kolonnen ”Kategori”, som findes i begge tabeller.

· Åben nu spurvehøg-tabellen og se, hvordan den har ændret sig. Feltnavnene er ændret og hvis du går ud til højre side i tabellen ses det, at der er blevet tilføjet et nyt felt ”KategoriFork.Forklaring”. Dette felt er hentet fra tabellen kategorifork.dbf, på basis af fælles værdier i feltet ”Kategori”. De to tabeller er nu flettede og denne fletning vises i én tabel. Fletningen er ikke permanent, og udføres, hver gang man åbner projektet igen. Derfor kan man ved at rette i tabellen kategorifork.dbf, ændre på kategorierne (teksten), uden at skulle rette i alle tabeller. Smart ikke!

· En fletning fjernes ved at højreklikke på temaet og vælge Joins and Relates>Remove Joins. 
Egne data

I skal nu til at arbejde lidt med at lave jeres egne temaer. Dette kan gøres på flere måder. Hvis man gerne vil lave et tema på basis af underliggende kort, kan man f.eks. tegne det direkte ind i ArcMap. Derfor vil vi først se på nogle grafiske funktioner og på, hvordan man tegner og retter i et tema.

Øvelse 7
I ArcMap kan man tegne almindelige grafiske elementer i kortvinduet, på samme måde som i MS Office programmerne. Det giver mulighed for at lægge figurer, skitser, ideer og kommentarer hen over et kort, hvilket er praktisk til præsentation. Disse grafik-elementer er rent visuelle og rummer ikke nogen bagvedliggende tabel, og deres position er ofte ret upræcis, afhængigt af din egen tålmodighed. Derfor er der andre, bedre måder at få biologiske data vist på, som vi kommer til senere.  

Lad være med at rode længe med denne øvelse, da der er vigtigere arbejde forude!

· Først skal tegneværktøjslinjen vises, hvis ikke den allerede er der

· Gå op under View>Toolbars og slå Draw til med et flueben
· Tegn nogle grafik elementer ved hjælp af værktøjerne. Du kan slette dem eller flytte dem enkeltvis ved at vælge dem med pilen (pointer).
· Tekst er ligeledes en form for grafik og med tekst-værktøjet kan du vælge mellem diverse måder at lave tekst på. Prøv dem af.

· Hvis du bliver træt af alle dine grafikelementer, kan du vælge Edit>Select all elements og trykke Delete, hvorefter dit møjsommeligt udførte arbejde vil forsvinde.

· Du kan ændre på farven og andre grafik-egenskaber under menuen Graphics>Properties.

· Læg mærke til at du kan tegne ind over kortet både i ”data view” og i ”layout view”.
Øvelse 8
Nu skal du et oprette et nyt tomt tema og tegne de enkelte elementer i det. Dette er en måde at konstruere et tema på, som kan anvendes ved mindre datasæt, uden alt for store krav til præcisionen. 

Det at oprette et nyt tema kommer ind under databasearbejde og den slags håndteres først og fremmest af ArcCatalog. Dvs. at temaet skal oprettes i ArcCatalog, men at selve editeringen (eller tegningen) i temaet skal foregå i ArcMap.
· Start med at finde frem til din folder ”GIS-projekter” i ArcCatalog. Højreklik på denne og vælg New>Shapefile. Du får nu mulighed for at bestemme om dit tema skal være et punkt, linje eller polygon-tema. Et tema kan kun være én af delene, så du må altså vælge og du vælger ”Point”. Navngiv det nye tema ”MitTema.shp”. 

· Træk MitTema.shp over i ArcMap og tænd for det. Der er naturligvis intet at se, da temaet stadig er tomt.

· Nu skal temaet gøres åbent til rettelser (editable) og det gøres ved at gå ind på editor værktøjslinjen og vælge start editing. Man skal vælge, hvilken folder man skal editere i – peg på den som indeholder dit tema på disken og vælg OK. Denne fremgangsmåde virker lidt omstændelig, men har noget at gøre med at ArcMap kan håndtere mange former for data og kan opkoble på databaser osv. 

· Ved hjælp af værktøjerne på editor værktøjslinjen kan du nu tegne punkter rundt omkring på kortet. Disse kunne du evt. sætte på bestemte koordinater.
· Hvis du vil tilføje tabelværdier, kan du åbne temaets tabel (bemærk at denne er ”editable” på den lille pen nede til højre) og skrive værdier ind i tabellen. Du kan også tilføje nye felter ved at vælge Options>Add Field og specificere feltets egenskaber. Disse kan ikke ændres efter at feltet er oprettet, så det er vigtigt at sætte f.eks. antallet af decimaler rigtigt fra starten.

· Når du synes at du har tegnet nok, vælger du Editor>Stop Editing og bekræfter at du vil gemme ændringerne. Du har nu lavet dit eget tema, med både figurer (prikker) og underliggende tabel. 

Øvelse 9
Nu kommer det endelig! Du skal prøve at importere dine egne data til en shape-fil.

Dine data ligger i en dBase-fil (eller til nød en tekst-fil) som beskrevet i hjemmeopgaven. 

· Som I så tidligere kan man kun lave nye shape-filer i ArcCatalog. Gå derfor ind i ArcCatalog og find frem til din dBase fil. Hvis du ikke har dine egne data med, kan du i stedet arbejde med tabellen c:\gisData\Lektion1\tabeller\grundtabel.dbf.

· Højreklik på dBase tabellen og vælg Create Feature Class>From XY Table
· Definer nu, hvilket fedt der er lat (Y-koordinat) og long (X-koordinat) og gem den nye shape fil i din egen mappe. I grundtabel.dbf skal du pege på felterne X_gcoord og Y_gcoord, som er genmeldingskoordinaterne for spurvehoeggenfundene. Dem har du set før.

· Herefter kan du f.eks. højreklikke på filen og sætte dens projektion til at være det ønskede, f.eks. UTM 32N

· Åben filen i ArcMap og se, hvor dygtig du har været til at måle præcist!

· Præsentér dine data på en pæn måde. Den mere komplicerede databehandling bliver du nok nødt til at vente med.

Øvelse 10

Vi har helt bevidst indlagt nogle fejl i mærkningsdataene. Der burde ikke ligge mærkninger uden for Danmarks grænser. 

Ved hjælp af din viden fra de første to lektioner, kan du oprense data og fjerne disse fejlposter. Udvælg dem og fjern dem fra temaet spurvehoegmaerk.shp.

Øvelse 11

Tænd for temaet med dine egne data. Lav selv et nyt tema med nogle linier eller polygoner, som du tegner mere eller mindre tilfældigt mellem dine prikker. Gem temaet og prøv at stille nogle forespørgsler mellem de to temaer, som f.eks. ”Find alle prikker der ligger tættere end 2 km på en linie” eller ”Find alle prikker, som er inden for nogle udvalgte polygoner”.

Undersøg de mange muligheder for rumlige forespørgsler.

Lektion 2
Udvidelser og raster-data
Nu skal vi til at arbejde med raster-data. Raster eller Grids er en flade af celler, som hver har en værdi. Raster bruges, hvor man ønsker at have en kontinuert overflade, som har en værdi i alle punkter. Da det er umuligt at få en unik værdi i alle punkter, bliver man nødt til at bestemme sig for en cellestørrelse. Denne afhænger af, hvilke baggrundsdata man har til rådighed og af formålet med at bruge rasteret. Hvis man f.eks. vil lave en højdemodel over Europa, har man sandsynligvis ikke brug for den samme opløsning, som hvis man vil lave et jordbundskort over en skov. Læg mærke til at jeg skrev en ”højdemodel”. Det kræver nemlig en model, eller en funktion, at lave et raster, da man modellerer de områder, som man ikke har direkte målinger fra. Funktionen er en interpolation, hvor enhver celles værdi baseres på nogle antagelser omkring de nærmeste målepunkter. Der findes mange forskellige måder at interpolere et raster på. Nogle er egnede til blødt kurvene flader, mens andre bedre kan håndtere flader med abrupte overgange. 
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Her skal I slå udvidelsen ”Spatial analyst” til og se på raster data. 

Denne udvidelse gør ArcMap i stand til at håndtere raster data. Der er mange muligheder fra Spatial Analyst’s værktøjslinje, men Spatial analyst har også mange gode funktioner, som man bliver nødt til kalde via f.eks. VBA kode. Vi vil her naturligvis nøjes med at bruge de let tilgængelige funktioner.

· Åben et nyt projekt i ArcMap og gem det under navnet Skandinavien. 

· Vælg Tools>Extensions og afkryds ”Spatial analyst” i den boks som kommer op.

· Gå til View>Toolbars og åben værktøjslinjen for Spatial Analyst

· Hent grid-temaet ”GisData/lektion2/Grids/DemScandUral”, som er en digital højdemodel over Europa. Suppler evt. med landekort, som ligger i mappen ”Themes”.

· Hvis du aktivérer temaet ”DemScandUral” kan du åbne dets tabel. Prøv at finde ud af, hvordan en grid-tabel adskiller sig fra en shape-tabel.

· En del funktioner kan ikke bruges på grids. Det drejer sig om de fleste funktioner, hvor man anvender klare afgrænsninger mellem features. Der er dog andre muligheder med grids. Prøv Info-værktøjet, Contour-værktøjet og histogram-værktøjet. Se hvilke muligheder du har. 

· Prøv også at ændre symbologien (”Legends”) for raster temaet og prøv at illustrere topografien i Skandinavien bedst muligt.
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Nu skal du lave dit eget grid.

Vi starter med den simpleste måde at gøre det på, som er at konvertere en shape-fil til grid. Hvis det skal være rigtig kedeligt, kan man konvertere en tom firkant, men vi prøver at gøre det med et kort over administrative zoner i Danmark.

· Hent kortet Admin98.shp fra ”../themes” ind i projektet ”Skandinavien”. 

· Brug ”Select by attributes” til at udvælge de zoner som ligger i Danmark, ved hjælp af feltet ”Cntry_name”. Danmark skal blive udvalgt – blå.

· Før man foretager sig de fleste operationer med Spatial Analyst er det vigtigt at sætte grid-definitionerne op. Dette gøres ved at

· Gå til Spatial Analyst værktøjslinjen og vælg Options. Nu får du mulighed for at definere, hvordan dit grid skal ligge og hvilken cellestørrelse det skal have mm.

· Sæt ”Output grid extent” til at være ”Same as display”, og ”Output grid cell size” til ”Same as DemScandural”.
· Gå nu til Spatial Analyst værktøjslinjen og vælg Spatial Analyst>Convert>Features to Raster.  Vælg feltet ”Pop_admin” til ”Field” for celle værdier”. Disse er værdierne, som griddet kommer til at vise. Gem grid’et under navnet DenmarkAdmin i folderen ”Themes”. 

· Du har nu lavet et grid over Danmark, som viser farve efter indbyggertallet – fortvivl ikke over tallene – de afspejler den amerikanske viden om verden (undskyld dette utidige politiske indlæg!).

· Vi vil nu gerne dele disse tal op i seks kategorier fra 1 til 6, i stedet for de eksakte tal. Man kunne vælge at gøre det rent grafisk, som I har gjort tidligere, men i forbindelse med analyse skal man omregne/klassificere data.

· Vælg Spatial Analyst>Reclassify. Du får nu mulighed for at konvertere ønskede værdier til nye værdier. Det kan være at du ønsker at alle værdier skal gøres til 1 (presence/absence), men lige nu skal du prøve at lave seks fornuftige kategorier. Brug ”Natural breaks”.

· Et nyt grid, ”Reclass Of DenmarkAdmin” er blevet lagt til øverst i TOC. Slet nu det forrige grid, da det nye er dit endemål. ArcView arbejder normalt med grids i hukommelsen uden at lagre dem på disken, hvilket gør det hurtigt og man undgår at producere store mængder af ”spild-grid” undervejs i processen. Derfor skal man huske at gemme det færdige grid separat.

· Højreklik på det nye ”reclassified” grid og vælg Make Permanentt. Gem grid’et som DKadminKat. Grids har ikke nogen filtype, som f.eks. shape-filer (.shp).
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Du skal nu prøve at interpolere dig frem til en overflade. Jeg har lavet nogle ”målepunkter” med højder fra et område i Ecuador. Forestil dig, at du har rejst Ecuador tyndt med en håndholdt GPS og noteret koordinater og højder og nu ønsker du at fremstille et kort over højden i Ecuador (en højdemodel) ud fra dine målepunkter.

Først skal du prøve at arbejde med ”Analysis environment”. Her kan man sætte diverse variable som definerer grid’et.

· Åben en ny Data Frame og kald den ”Ecuador”

· Hent temaerne ”Borders.shp” og ”Plants.shp” ind i ”Ecuador”.

· Hent grid’ene ”Alt1000” og ”Mask” ind.

· Sæt analysis properties som tidligere. ”Extent” definerer, hvor grid’et starter, så det er vigtigt for at det nederste venstre hjørne er i grid’ets startpunkt. Sæt extent til ”Same as Alt1000”. Sæt også analysis cell size til ”Same as Alt1000”. Tryk OK.

· Aktivér nu ”Plants.shp” og vælg Spatial Analyst>Interpolate to raster>Inverse Distance Weighted. Sæt Z-value field til ”Altitude”. Z-value field er den variabel, som du ønsker at interpolere over – i dette tilfælde højden. Tryk Ok

· Se nu på det nye grid du har fået lavet og sammenlign det med ”Alt1000”.

· Gå til Surface Analysis>Hillshade og se, hvad der sker. Det giver et godt indtryk af højden ikke! Der er dog et problem med dit nye grid. Det fortsætter alt for langt væk fra målepunkterne. For at definere, hvor langt man skal gå ud, bruger man en ”mask”. 

· Gå til Analysis Properties og sæt masken til at være ”Mask”. Gentag interpolationen og se forskellen. Dette giver mere mening.
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Her er lidt kreativ udfordring! Brug løs af hvad I har lært.

Hent grid’et ”DemSoutham” ind i en ny data frame. Det er en højdemodel over Sydamerika og andre landområder. Værdierne ude i vandet viser at der er omkring 65 km højt der! Dette er naturligvis blot en kode til at signalere vand med. Find ud af at ”rense” kortet for værdierne ude i vandet og evt. isolere det til kun at omfatte Sydamerika og ikke andre landområder. Husk at dit tidligere analysis extent stadig gælder.

(Hints: ”Reclassification” kan måske hjælpe dig. Prøv evt. også ”Raster Calculator”)

Extensions og scripts

I denne sidste lektion skal vi samle lidt op på områder vi mangler fra de øvrige lektioner, samt prøve at arbejde med diverse extensions og scripts.

Der er stadig meget at lære om GIS, men efter denne introduktion skulle I gerne føle at I har et rimeligt kendskab til hvad GIS er og hvordan det anvendes. Først og fremmest skal I nu gerne vide, hvor hurtigt og nemt man kan komme i gang med sit eget GIS arbejde. Herfra kan jeg ikke gøre meget mere end I selv kan finde ud af ved ydmyge studier af litteratur og hjælpefunktioner. Må kraften være med jer!

Først skal vi skal arbejde med to meget nyttige extensions, der følger med i ArcView pakken:

Geoprocessing

Geoprocessing giver mulighed for at lave nogle rigtig nyttige operationer med shape-filer, som f.eks. at lægge dem sammen, trække dem fra hinanden og meget andet. Vær opmærksom på at Geoprocessing ikke er i stand til at håndtere raster data. Dertil må man bruge Spatial analyst.
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Her skal I prøve at udføre en række øvelser med Geoprocessing wizard.

· Åben et nyt projekt og kald det ”Beskyttelseszoner”

· Hent temaer over EF-fuglebeskyttelsesområder og danske natur- og vildtreservater. Det er de to temaer ”EFfuglebeskomr.shp” og ”reservat_region.shp”, der ligger i C:\GIS-data\Lektion1\Temaer\Beskyttelsesomrader. Tænd temaerne og læg mærke til deres koordinater. Det er UTM-koordinater, som er skrevet i meter fra nederste venstre hjørne af UTM-zonen. 

· Vi vil nu gerne lægge disse to temaer sammen for at få et samlet kort over beskyttede områder. Vælg Tools>Geoprocessing wizard. Nu åbnes der en guide. Prøv at markere de forskellige radioknapper og se beskrivelsen af funktionen ovre til højre i vinduet. 

· Vælg ”Merge themes together” og tryk Next. Vælg de to temaer ”reservat_region” og ”EFfuglebeskomr”. Funktionen kræver at de to temaer har samme shape-format, dvs. punkter, linier eller polygoner. Her er der tale om to polygon-temaer. Under ”Use fields from” vælger man, hvilket tema man skal bibeholde felterne fra (dvs. kolonnerne). Hvis de to temaer har de samme kolonnenavne vil kolonnerne passe sammen, men hvis det andet tema (det ikke-valgte tema) har andre/flere kolonner, vil de ikke komme med i det nye tema.

· Specificér navn og placering af den nye fil og tryk Finish. Den nye fil vil nu blive lagt til TOC som tema.

· Åben tabellen, kør ned igennem den og læg mærke til, hvordan de to temaer er blevet lagt sammen.

Øvelse 17

· Lav en ny data frame, kald den ”Regioner” og hent temaet Admin98.shp, som ligger i c:\gis-data\lektion2\themes. Admin98 er et verdenskort delt op i administrative zoner, så godt det har kunnet lade sig gøre. Åben tabellen og se på felterne. 

· De administrative zoner er meget små. I vores imperiale tankegang vil vi gerne slå lande fra samme region sammen til et et land. Prøv at gøre dette, ved hjælp af funktionen ”dissolve” i Geoprocessing. Kald dit nye tema ”Regioner”

ArcToolbox

Set projections
Project Wizard kan konvertere shape-filer til en ny projektion, dvs. omregne koordinaterne til et andet koordinatsæt, f.eks. fra decimalgrader til UTM-koordinater. Det er en fordel at alle temaer i en data frame er i de samme koordinater, så derfor kan det være nødvendigt at konvertere. ArcGis 8.x har ”on-the-fly” projektion, hvilket vil sige, at data løbende konverteres, men hvis man skal bruge temaet flere gange vil det være mest effektivt at lave en rigtig projektion med det samme.
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Omprojicering af et tema fra UTM til decimalgrader

· Hent temaet ”newkystii.shp” (Danmarkskortet) ind i data fram’en ”Beskyttelseszoner” og tænd for det. Ups, det kan man ikke se sammen med de andre temaer. Aktivér newkystii.shp og tryk på knappen ”Zoom to active theme(s)”. Nu kan du se newkystii, men uden de andre temaer. Se på koordinaterne. De er graddata. Vi er altså kommet til at indlæse temaer i to forskellige koordinatsystemer. Det kan ikke lade sig gøre at vise alle temaerne i det samme View

· For at vise dem sammen bliver vi nødt til at projicere newkystii.shp over til UTM-koordinater. Dette skal man gøre i det View, som har de oprindelige koordinater, hvorefter man åbner temaet i View’et med de ønskede koordinater, dvs. at vi kan projicere fra ”Regioner”, som er i decimalgrader og derefter åbne det nye tema i ”Beskyttelseszoner”, som er i UTM-grader.

· Slå extension ”Projection utility wizard” til og hent newkystii.shp ind i View’et Regioner.

· Aktivér newkystii.shp og vælg File>ArcView projection utility
· Nu kommer der en guide op. Dit input-koordinatsystem er GCS_WGS_1984 i grader og du vil gerne projicere til WGS_1984_UTM_zone_32N i meter. Prøv at finde ud af det. Projektionen tager muligvis lidt tid at behandle.

· Gå til dit View ”Beskyttelseszoner” og hent det nye projicerede tema ind. Nu skulle alle tre temaer gerne kunne vises sammen.
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”Animal movement” er en gratis extension fra USGS, som kan hentes over nettet. Den rummer mange praktiske funktioner for zoologer og populationsbiologer. I er nok mindst lige så kvalificerede som jeg til at forholde jer til funktionerne og deres statistiske værdi, så her er det meningen at I bare skal lege løs.

· For at slå Animal movement til, skal du kopiere filen ”c:\gis-intro\lektion4\animalMovement2.avx” til folderen ”c:\esri\av_gis30\arcView\ext32”. Nu kan du slå ”Animal movement” til i extensions

· Åben et nyt View ”Movement” og hent temaerne ”Spurvehoegmaerk.shp” og ”Spurvehoeggenf.shp” fra c:\gis-intro\lektion1\temaer.

· Brug de to temaer til at undersøge nogle af de mange forskellige funktioner i Animal Movement.
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Med ArcView følger der en hel del extensions og scripts, som du selv kan læse ind og køre. Disse er beskrevet i hjælpefunktionen. 

· Åben hjælpen til ArcView (F1) og find et script der kan lægge X og Y koordinater til features i en tabel

· Læs scriptet ind i Script-editoren, kompilér det og kør det på et tema (Spurvehoeggenf.shp).
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Find et script under www.esri.com. Hent det ned og prøv at køre det.
